网站首页

金沙4066官网源码安装

30 6月 , 2019  

CentOS 5.5 PDF转TXT

 

安装djvulibre-3.5.24
下载地址:
下载压缩包解压好
# ./configure
# make && make install && make clean

   关于在Linux下安装 openfetion (源码安装)

安装poppler-0.18.3.tar.gz
下载地址:
# ./configure –enable-xpdf-headers –disable-poppler-qt4 –disable-cms
–disable-poppler-cpp
# make && make install && make clean
安装poppler过程出错处理:
Package requirements (fontconfig >= 2.0.0) were not met:
解决办法:通过yum 安装 fontconfig-devel,再configure通过。

    

配置时必需添加 –enable-xpdf-headers
参数,否则安装pdf2djvu-0.7.12时会提示 fatal error: GfxState.h: No such
file or directory

    首先给一个下载地址:

安装pdf2djvu-0.7.12
下载地址:
# ./configure –prefix=/usr/local/pdf2djvu-0.7.12
–without-graphicsmagick –without-xslt
# make && make install && make clean

    

可以指定使用的编译器
#./configure CFLAGS=”-O3″ CC=”gcc462″ CXXFLAGS=”-O3″ CXX=”g++462″
–prefix=/usr/local/pdf2djvu-0.7.12 –without-graphicsmagick
–without-xslt

    理想状态下:./configure

设置库的头文件查找路径,以下方式紧当前shell有用
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH
export PKG_CONFIG_PATH=/usr/lib/pkgconfig:$PKG_CONFIG_PATH

                         make

 

                         sudo make install 就可以了!

错误处理:
checking for DJVULIBRE… no
configure: error: Package requirements (ddjvuapi >= 3.5.17) were not
met:
No package ‘ddjvuapi’ found
设置库的头文件查找路径
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH

 

提示POPPLER版本过低
checking for POPPLER… no
configure: error: Package requirements (poppler-splash >= 0.7.3) were
not met:
下载新版安装

    但是会出现一些问题:

提示找不到:GfxState.h
g++ -fopenmp -g -O2 -Wall -Werror=overloaded-virtual -pthread
-I/usr/local/include  -I/usr/local/include/poppler      -c -o config.o
config.cc
cc1plus: error: unrecognized command line option
“-Werror=overloaded-virtual”
重新安装poppler-0.18.3.tar.gz 添加 –enable-xpdf-headers 参数

 

gcc编译器版本太低
安装最新版gcc方法参看“CentOS 5.5 手动安装 GCC4.6.2”
http://www.linuxidc.com/Linux/2014-01/95388.htm

    首先是对于库的要求:openssl , libxml2
,gtk+2.0,如果在安装(./configure)的过程中出现问题,那么可能是版本OLD或者没有,所以需要
安装一下:

使用方法:
# ./pdf2djvu -o /data/sphinx_doc_zhcn_0.9.djvu
/data/sphinx_doc_zhcn_0.9.pdf
# djvutxt /data/sphinx_doc_zhcn_0.9.djvu
/data/sphinx_doc_zhcn_0.9.txt
djvutxt默认在/usr/bin目录下

sudo apt-get install libgtk2-dev

更多CentOS相关信息见CentOS 专题页面 http://www.linuxidc.com/topicnews.aspx?tid=14

 

金沙4066官网 1

sudo apt-get install libssl-dev

 

apt-get install libxml2-dev

 

sudo apt-get install pkg-config

 

然后再configure就可以了,再make,再sudo make install

 

 

但是在configure过程还可能出现一个问题哦:

checking for LIBXML2… configure: error: Package
requirements(libxml-2.0 >= 2.6) were not met:

金沙4066官网, 

No package ‘libxml-2.0’ found

 

Consider adjusting the PKG_CONFIG_PATH environment variable ifyou

installed software in a non-standard prefix.

 

Alternatively, you may set the environment variablesLIBXML2_CFLAGS

and LIBXML2_LIBS to avoid the need to call pkg-config.

See the pkg-config man page for more details.

 

这其实就是环境变量问题,解决:

 

确定 /usr/local/libxml2/lib/pkgconfig 目录下有 libxml-2.0.pc

然后
exportPKG_CONFIG_PATH=/usr/local/libxml2/lib/pkgconfig:$PKG_CONFIG_PATH

 

 

然后就会安装OK!

 

好,然后我们测试:启动飞信(应用程序—>互联网—->fetion)

但是可能会启动不了,解决办法:

需要安装下面三个包

sudo apt-get install libcurl3

sudo apt-get install automake libc-dev g++libcurl4-openssl-dev

sudo apt-get install build-essential

 

然后在启动,OK////

 

 

 

摘自 shanshanpt的专栏

openfetion (源码安装)
首先给一个下载地址:
理想状态下:./configure make sudo make install 就可以…


相关文章

发表评论

电子邮件地址不会被公开。 必填项已用*标注

网站地图xml地图